Secondary menu

File to import not found or unreadable: compass/css3/gradient

nrussell's picture

File to import not found or unreadable: compass/css3/gradient

Written by Nick Russell on

Using compass 0.12.2 (and a few earlier versions of compass), it should be noted that compass/css3/gradient has been deprecated. This means that if you try and include the gradient library like so:

@import "compass/css3/gradient"

you are most likely bound to run into these errors when trying to compile or watch your sass projects.

Replace compass/css3/gradient with compass/css3/images

Thats right. The most recent library you'll want to use is the images library. So, if you have a project that was using the gradient library, run the following on your site after you make the @import change.

compass clean
compass compile
compass watch

You will still have access to all the great mixins that came with the gradient library, you'll just be using the most recent images library instead. See http://compass-style.org/reference/compass/css3/images/ for more information.